Jump to: navigation, search

TTN LimeSDR Workshop

Revision as of 10:13, 1 February 2018 by AndrewBack (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

Preparatory information for the Implementing Internet of Things with Software Defined Radio workshop which will be held on Thursday 1st February 2018 at The Things Network Conference.

1 Requirements

1.1 Hardware

A laptop with USB (ideally 3.0) and at least 2GB RAM is required.

1.2 Software

The software requirements detailed below must be installed in advance of the workshop.

Do not leave installation until the morning of 1st February!

1.2.1 Operating system

The reference operating system platform is Ubuntu and while software requirements can be met with other operating systems, we are unable to directly support these and if Apple OS X or Windows is used, you should be confident that you can resolve any issues that might arise.

1.2.2 Lime Suite

Lime Suite provides the SDR driver for LimeSDR platforms and must be installed.

1.2.3 GNU Octave

Octave will be used for some of the examples.

With Ubuntu the following packages must be installed:

With Windows these will be automatically installed.

1.2.4 Examples

The workshop examples and supporting materials can be downloaded from:

http://downloads.myriadrf.org/workshops/LimeSDR_Jan18/